{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3230 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-3230 is a medium-severity vulnerability in libwww-perl LWP::Protocol::https, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3230 and fix it if it is affected.\n\nWhat it is: CVE-2014-3230 is a medium-severity vulnerability in libwww-perl LWP::Protocol::https, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3230 in the wild and no public exploit code.\n\nAffected product: libwww-perl LWP::Protocol::https. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3230/ (Markdown: https://insights.sbomify.com/CVE-2014-3230/index.md)","id":"CVE-2014-3230","markdown":"https://insights.sbomify.com/CVE-2014-3230/index.md","name":"CVE-2014-3230","record":{"aliases":["ALPINE-CVE-2014-3230","DEBIAN-CVE-2014-3230","GHSA-7x2q-v99p-jm92","MGASA-2014-0257","UBUNTU-CVE-2014-3230","USN-2292-1","openSUSE-SU-2024:10239-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Perl HTTP library","requires_auth":"none","summary":"Attackers can disable SSL certificate validation in libwww-perl by setting specific environment variables, allowing man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"\\","vendor":"lwp\\"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"The libwww-perl LWP::Protocol::https module 6.04 through 6.06 for Perl, when using IO::Socket::SSL as the SSL socket class, allows attackers to disable server certificate validation via the (1) HTTPS_CA_DIR or (2) HTTPS_CA_FILE environment variable.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in LWP::Protocol::https","id":"CVE-2014-3230","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2014"},"n_packages":1,"n_references":5,"next":{"headline":"SOAPpy vulnerable to XML External Entity attacks","id":"CVE-2014-3242"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.06-1.4"],"introduced":["0"],"last_affected":[],"package":"perl-LWP-Protocol-https","purl":"pkg:rpm/opensuse/perl-LWP-Protocol-https\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10239-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2014-3227"},"products":["LWP::Protocol::https"],"published":"2020-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["libwww-perl"]},"summary":"Attackers can disable SSL certificate validation in libwww-perl by setting specific environment variables, allowing man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2014-3230/"}