{"answers":{"affected":"3 open source packages ship an affected version, including soappy and SOAPpy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3243 in the wild and no public exploit code.","fix":"Upgrade soappy to 0.12.6 or later.","what":"CVE-2014-3243 is a medium-severity denial of service vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3243 and fix it if it is affected.\n\nWhat it is: CVE-2014-3243 is a medium-severity denial of service vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3243 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- soappy (PyPI): affected all versions; fixed in 0.12.6\n- soappy (PyPI): affected all versions; fixed in 0.12.6\n- SOAPpy (PyPI): affected all versions; fixed in 0.12.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3243/ (Markdown: https://insights.sbomify.com/CVE-2014-3243/index.md)","id":"CVE-2014-3243","markdown":"https://insights.sbomify.com/CVE-2014-3243/index.md","name":"CVE-2014-3243","record":{"aliases":["GHSA-2gh8-gr6x-7q26","PYSEC-2026-923","UBUNTU-CVE-2014-3243"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SOAP library","requires_auth":"none","summary":"Remote attackers can cause denial of service via crafted SOAP requests exploiting recursive entity expansion in the SOAPpy library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"soappy","vendor":"makina-corpus"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"SOAPpy 0.12.5 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted SOAP request containing a large number of nested entity references.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SOAPpy vulnerable to XXE attacks","id":"CVE-2014-3243","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":3,"n_references":5,"next":{"headline":"XML external entity in n/a","id":"CVE-2014-3244"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0"],"last_affected":[],"package":"SOAPpy","purl":null,"source":"GHSA-2gh8-gr6x-7q26"},{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0"],"last_affected":[],"package":"soappy","purl":"pkg:pypi/soappy","source":"GHSA-2gh8-gr6x-7q26"},{"ecosystem":"PyPI","fixed":["0.12.6"],"introduced":["0"],"last_affected":[],"package":"soappy","purl":"pkg:pypi/soappy","source":"PYSEC-2026-923"}],"prev":{"headline":"SOAPpy vulnerable to XML External Entity attacks","id":"CVE-2014-3242"},"products":["n/a"],"published":"2014-05-12","related":[{"cvss_score":5,"headline":"SOAPpy vulnerable to XML External Entity attacks","id":"CVE-2014-3242","kev_date_added":null,"published":"2014-05-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via crafted SOAP requests exploiting recursive entity expansion in the SOAPpy library.","url":"https://insights.sbomify.com/CVE-2014-3243/"}