# CVE-2014-3243: SOAPpy vulnerable to XXE attacks

> Remote attackers can cause denial of service via crafted SOAP requests exploiting recursive entity expansion in the SOAPpy library.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2gh8-gr6x-7q26, PYSEC-2026-923, UBUNTU-CVE-2014-3243

## What is CVE-2014-3243?

CVE-2014-3243 is a medium-severity denial of service vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SOAPpy 0.12.5 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted SOAP request containing a large number of nested entity references.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2014-3243?

3 open source packages ship an affected version, including soappy and SOAPpy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `soappy` | PyPI | All versions | 0.12.6 |
| `soappy` | PyPI | All versions | 0.12.6 |
| `SOAPpy` | PyPI | All versions | 0.12.6 |

Products: Makina-Corpus Soappy.

## How do I fix CVE-2014-3243?

Upgrade soappy to 0.12.6 or later.

## Is CVE-2014-3243 being exploited?

There is no known exploitation of CVE-2014-3243 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-3242](https://insights.sbomify.com/CVE-2014-3242/): SOAPpy vulnerable to XML External Entity attacks (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3243 and fix it if it is affected.

What it is: CVE-2014-3243 is a medium-severity denial of service vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3243 in the wild and no public exploit code.

Affected packages and fixed versions:
- soappy (PyPI): affected all versions; fixed in 0.12.6
- soappy (PyPI): affected all versions; fixed in 0.12.6
- SOAPpy (PyPI): affected all versions; fixed in 0.12.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3243/ (Markdown: https://insights.sbomify.com/CVE-2014-3243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3243
- OSV: https://osv.dev/vulnerability/CVE-2014-3243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3243/
Summaries are generated and may contain mistakes; the official description above is the record.
