CVE-2014-3248 facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability
Local attackers can escalate privileges by placing malicious files in the current working directory when using older Ruby versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-3248?
CVE-2014-3248 is a medium-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 16 Nov 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
Weakness: CWE-17
Which versions are affected by CVE-2014-3248?
12 open source packages ship an affected version, including puppet, facter and hiera. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | All versions | 2.7.26 |
puppet RubyGems | All versions | 2.7.26 |
puppet RubyGems | From 3.0.0 | 3.6.2 |
puppet RubyGems | From 3.0.0 | 3.6.2 |
facter RubyGems | All versions | 1.7.6 |
facter RubyGems | All versions | 1.7.6 |
6 more packages
facter RubyGems | From 2.0.0 | 2.0.2 |
facter RubyGems | From 2.0.0 | 2.0.2 |
hiera RubyGems | All versions | 1.3.4 |
hiera RubyGems | All versions | 1.3.4 |
mcollective-client RubyGems | All versions | 2.5.2 |
mcollective-client RubyGems | All versions | 2.5.2 |
Linux distribution packages (1)
rubygem-facter openSUSE:Tumbleweed | All versions | 1.3.4-3.5 |
Products include Puppet Facter, Puppet Hiera, Puppet Marionette Collective, Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Facter.
How do I fix CVE-2014-3248?
Upgrade puppet to a fixed version for your release line: 2.7.26 or 3.6.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2014-3248 being exploited?
There is no known exploitation of CVE-2014-3248 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2014-3248, GHSA-92v7-pq4h-58j5, UBUNTU-CVE-2014-3248, openSUSE-SU-2024:10565-1.