# CVE-2014-3248: facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability

> Local attackers can escalate privileges by placing malicious files in the current working directory when using older Ruby versions.

- **Severity:** Medium 6.2 (`AV:L/AC:H/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3248, GHSA-92v7-pq4h-58j5, UBUNTU-CVE-2014-3248, openSUSE-SU-2024:10565-1

## What is CVE-2014-3248?

CVE-2014-3248 is a medium-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 16 Nov 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.

Weakness: CWE-17

## Which versions are affected by CVE-2014-3248?

12 open source packages ship an affected version, including puppet, facter and hiera. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | All versions | 2.7.26 |
| `puppet` | RubyGems | All versions | 2.7.26 |
| `puppet` | RubyGems | From 3.0.0 | 3.6.2 |
| `puppet` | RubyGems | From 3.0.0 | 3.6.2 |
| `facter` | RubyGems | All versions | 1.7.6 |
| `facter` | RubyGems | All versions | 1.7.6 |
| `facter` | RubyGems | From 2.0.0 | 2.0.2 |
| `facter` | RubyGems | From 2.0.0 | 2.0.2 |
| `hiera` | RubyGems | All versions | 1.3.4 |
| `hiera` | RubyGems | All versions | 1.3.4 |
| `mcollective-client` | RubyGems | All versions | 2.5.2 |
| `mcollective-client` | RubyGems | All versions | 2.5.2 |
| `rubygem-facter` | openSUSE:Tumbleweed | All versions | 1.3.4-3.5 |

Products: Puppet Facter, Puppet Hiera, Puppet Marionette Collective, Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Facter.

## How do I fix CVE-2014-3248?

Upgrade puppet to a fixed version for your release line: 2.7.26 or 3.6.2.

## Is CVE-2014-3248 being exploited?

There is no known exploitation of CVE-2014-3248 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2015-1426](https://insights.sbomify.com/CVE-2015-1426/): Puppet Labs Facter allows local users to obtain sensitive Amazon EC2 IAM instance metadata (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3248 and fix it if it is affected.

What it is: CVE-2014-3248 is a medium-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 16 Nov 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3248 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected all versions; fixed in 2.7.26
- puppet (RubyGems): affected all versions; fixed in 2.7.26
- puppet (RubyGems): affected from 3.0.0; fixed in 3.6.2
- puppet (RubyGems): affected from 3.0.0; fixed in 3.6.2
- facter (RubyGems): affected all versions; fixed in 1.7.6
- facter (RubyGems): affected all versions; fixed in 1.7.6
- facter (RubyGems): affected from 2.0.0; fixed in 2.0.2
- facter (RubyGems): affected from 2.0.0; fixed in 2.0.2
- hiera (RubyGems): affected all versions; fixed in 1.3.4
- hiera (RubyGems): affected all versions; fixed in 1.3.4
- mcollective-client (RubyGems): affected all versions; fixed in 2.5.2
- mcollective-client (RubyGems): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3248/ (Markdown: https://insights.sbomify.com/CVE-2014-3248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3248
- OSV: https://osv.dev/vulnerability/CVE-2014-3248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3248/
Summaries are generated and may contain mistakes; the official description above is the record.
