{"answers":{"affected":"3 open source packages ship an affected version, including ipython. It affects 3 products.","exploited":"There is no known exploitation of CVE-2014-3429 in the wild and no public exploit code.","fix":"Upgrade ipython to 1.2.0 or later.","what":"CVE-2014-3429 is a medium-severity code injection vulnerability in Opensuse Opensuse, published on 7 Aug 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3429 and fix it if it is affected.\n\nWhat it is: CVE-2014-3429 is a medium-severity code injection vulnerability in Opensuse Opensuse, published on 7 Aug 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3429 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ipython (PyPI): affected from 0.12; fixed in 1.2.0\n- ipython (PyPI): affected from 0.12; fixed in 1.2.0\n- ipython (PyPI): affected from 0.12; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3429/ (Markdown: https://insights.sbomify.com/CVE-2014-3429/index.md)","id":"CVE-2014-3429","markdown":"https://insights.sbomify.com/CVE-2014-3429/index.md","name":"CVE-2014-3429","record":{"aliases":["DEBIAN-CVE-2014-3429","GHSA-75cw-5cgv-g853","MGASA-2014-0320","PYSEC-2014-21"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"IPython Notebook","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code in IPython Notebook by exploiting unvalidated websocket origins and kernel IDs via a crafted page.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ipython_notebook","vendor":"ipython"},{"product":"mageia","vendor":"mageia"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute arbitrary code by leveraging knowledge of the kernel id and a crafted page.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"IPython Notebook vulnerable to improper validation of the origin of websocket requests","id":"CVE-2014-3429","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"code_injection","year":"2014"},"n_packages":3,"n_references":9,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-3430"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0.12"],"last_affected":[],"package":"ipython","purl":null,"source":"GHSA-75cw-5cgv-g853"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0.12"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"GHSA-75cw-5cgv-g853"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0.12"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"PYSEC-2014-21"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-3428"},"products":["n/a"],"published":"2014-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code in IPython Notebook by exploiting unvalidated websocket origins and kernel IDs via a crafted page.","url":"https://insights.sbomify.com/CVE-2014-3429/"}