# CVE-2014-3429: IPython Notebook vulnerable to improper validation of the origin of websocket requests

> Remote attackers can execute arbitrary code in IPython Notebook by exploiting unvalidated websocket origins and kernel IDs via a crafted page.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3429, GHSA-75cw-5cgv-g853, MGASA-2014-0320, PYSEC-2014-21

## What is CVE-2014-3429?

CVE-2014-3429 is a medium-severity code injection vulnerability in Opensuse Opensuse, published on 7 Aug 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute arbitrary code by leveraging knowledge of the kernel id and a crafted page.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-3429?

3 open source packages ship an affected version, including ipython. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipython` | PyPI | From 0.12 | 1.2.0 |
| `ipython` | PyPI | From 0.12 | 1.2.0 |
| `ipython` | PyPI | From 0.12 | 1.2.0 |

Products: Ipython Ipython Notebook, Mageia Mageia, Opensuse Opensuse.

## How do I fix CVE-2014-3429?

Upgrade ipython to 1.2.0 or later.

## Is CVE-2014-3429 being exploited?

There is no known exploitation of CVE-2014-3429 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3429 and fix it if it is affected.

What it is: CVE-2014-3429 is a medium-severity code injection vulnerability in Opensuse Opensuse, published on 7 Aug 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3429 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipython (PyPI): affected from 0.12; fixed in 1.2.0
- ipython (PyPI): affected from 0.12; fixed in 1.2.0
- ipython (PyPI): affected from 0.12; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3429/ (Markdown: https://insights.sbomify.com/CVE-2014-3429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3429
- OSV: https://osv.dev/vulnerability/CVE-2014-3429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3429/
Summaries are generated and may contain mistakes; the official description above is the record.
