# CVE-2014-3474: OpenStack Horizon Cross-site scripting (XSS) vulnerability

> Authenticated users can inject arbitrary scripts via network names in the Launch Instance menu, potentially compromising other users' sessions.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3474, GHSA-j57p-g33w-95c5, PYSEC-2026-644, UBUNTU-CVE-2014-3474

## What is CVE-2014-3474?

CVE-2014-3474 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 31 Oct 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in horizon/static/horizon/js/horizon.instances.js in the Launch Instance menu in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2 allows remote authenticated users to inject arbitrary web script or HTML via a network name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-3474?

3 open source packages ship an affected version, including horizon. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `horizon` | PyPI | All versions | 8.0.0a0 |
| `horizon` | PyPI | All versions | 8.0.0a0 |
| `horizon` | PyPI | All versions | 8.0.0a0 |

Products: Openstack Horizon, Opensuse Opensuse.

## How do I fix CVE-2014-3474?

Upgrade horizon to 8.0.0a0 or later.

## Is CVE-2014-3474 being exploited?

There is no known exploitation of CVE-2014-3474 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2012-2144](https://insights.sbomify.com/CVE-2012-2144/): OpenStack Horizon Session Fixation (medium 6.8)
- [CVE-2022-45582](https://insights.sbomify.com/CVE-2022-45582/): Horizon Web Dashboard Open Redirect vulnerability (medium 6.1)
- [CVE-2026-55748](https://insights.sbomify.com/CVE-2026-55748/): OpenStack Horizon RC file generation does not escape special characters in project names (medium 6.0)
- [CVE-2012-3540](https://insights.sbomify.com/CVE-2012-3540/): Open redirect in n/a (medium 5.8)
- [CVE-2013-4471](https://insights.sbomify.com/CVE-2013-4471/): Auth bypass in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3474 and fix it if it is affected.

What it is: CVE-2014-3474 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 31 Oct 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3474 in the wild and no public exploit code.

Affected packages and fixed versions:
- horizon (PyPI): affected all versions; fixed in 8.0.0a0
- horizon (PyPI): affected all versions; fixed in 8.0.0a0
- horizon (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3474/ (Markdown: https://insights.sbomify.com/CVE-2014-3474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3474
- OSV: https://osv.dev/vulnerability/CVE-2014-3474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3474/
Summaries are generated and may contain mistakes; the official description above is the record.
