{"answers":{"affected":"2 open source packages ship an affected version, including activerecord. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-3482 in the wild and no public exploit code.","fix":"Upgrade activerecord to 3.2.19 or later.","what":"CVE-2014-3482 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3482 and fix it if it is affected.\n\nWhat it is: CVE-2014-3482 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3482 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activerecord (RubyGems): affected from 2.0.0; fixed in 3.2.19\n- activerecord (RubyGems): affected from 2.0.0; fixed in 3.2.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3482/ (Markdown: https://insights.sbomify.com/CVE-2014-3482/index.md)","id":"CVE-2014-3482","markdown":"https://insights.sbomify.com/CVE-2014-3482/index.md","name":"CVE-2014-3482","record":{"aliases":["DEBIAN-CVE-2014-3482","GHSA-mhwp-qhpc-h3jm","RHSA-2014:0876"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands in Ruby on Rails applications via improper bitstring quoting in the PostgreSQL adapter.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.","ecosystems":["Red Hat:rhel_software_collections:1::el6","Red Hat:rhel_software_collections:1::el7","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection in Active Record","id":"CVE-2014-3482","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"sql_injection","year":"2014"},"n_packages":6,"n_references":8,"next":{"headline":"Active Record contains SQL Injection via improper range quoting","id":"CVE-2014-3483"},"packages":[{"ecosystem":"RubyGems","fixed":["3.2.19"],"introduced":["2.0.0"],"last_affected":[],"package":"activerecord","purl":null,"source":"GHSA-mhwp-qhpc-h3jm"},{"ecosystem":"RubyGems","fixed":["3.2.19"],"introduced":["2.0.0"],"last_affected":[],"package":"activerecord","purl":"pkg:gem/activerecord","source":"GHSA-mhwp-qhpc-h3jm"},{"ecosystem":"Red Hat:rhel_software_collections:1::el6","fixed":["1:3.2.8-8.2.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord","source":"RHSA-2014:0876"},{"ecosystem":"Red Hat:rhel_software_collections:1::el6","fixed":["1:3.2.8-8.2.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord-doc","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord-doc","source":"RHSA-2014:0876"},{"ecosystem":"Red Hat:rhel_software_collections:1::el7","fixed":["1:3.2.8-8.2.el7"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord","source":"RHSA-2014:0876"},{"ecosystem":"Red Hat:rhel_software_collections:1::el7","fixed":["1:3.2.8-8.2.el7"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-activerecord-doc","purl":"pkg:rpm/redhat/ruby193-rubygem-activerecord-doc","source":"RHSA-2014:0876"}],"prev":{"headline":"XML external entity in n/a","id":"CVE-2014-3481"},"products":["n/a"],"published":"2014-07-07","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands in Ruby on Rails applications via improper bitstring quoting in the PostgreSQL adapter.","url":"https://insights.sbomify.com/CVE-2014-3482/"}