# CVE-2014-3482: SQL Injection in Active Record

> Remote attackers can execute arbitrary SQL commands in Ruby on Rails applications via improper bitstring quoting in the PostgreSQL adapter.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3482, GHSA-mhwp-qhpc-h3jm, RHSA-2014:0876

## What is CVE-2014-3482?

CVE-2014-3482 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-3482?

2 open source packages ship an affected version, including activerecord. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 2.0.0 | 3.2.19 |
| `activerecord` | RubyGems | From 2.0.0 | 3.2.19 |
| `ruby193-rubygem-activerecord` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:3.2.8-8.2.el6 |
| `ruby193-rubygem-activerecord-doc` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:3.2.8-8.2.el6 |
| `ruby193-rubygem-activerecord` | Red Hat:rhel_software_collections:1::el7 | All versions | 1:3.2.8-8.2.el7 |
| `ruby193-rubygem-activerecord-doc` | Red Hat:rhel_software_collections:1::el7 | All versions | 1:3.2.8-8.2.el7 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2014-3482?

Upgrade activerecord to 3.2.19 or later.

## Is CVE-2014-3482 being exploited?

There is no known exploitation of CVE-2014-3482 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3482 and fix it if it is affected.

What it is: CVE-2014-3482 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3482 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 2.0.0; fixed in 3.2.19
- activerecord (RubyGems): affected from 2.0.0; fixed in 3.2.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3482/ (Markdown: https://insights.sbomify.com/CVE-2014-3482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3482
- OSV: https://osv.dev/vulnerability/CVE-2014-3482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3482/
Summaries are generated and may contain mistakes; the official description above is the record.
