CVE-2014-3483 Active Record contains SQL Injection via improper range quoting

High 7.5 Published Updated

Remote attackers can execute arbitrary SQL commands in Ruby on Rails applications via improper range quoting in the PostgreSQL adapter.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3483?

CVE-2014-3483 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

Weakness: CWE-89

Which versions are affected by CVE-2014-3483?

4 open source packages ship an affected version, including activerecord. It affects 1 product.

PackageAffectedFixed in
activerecord RubyGemsFrom 4.0.04.0.7
activerecord RubyGemsFrom 4.0.04.0.7
activerecord RubyGemsFrom 4.1.04.1.3
activerecord RubyGemsFrom 4.1.04.1.3
Linux distribution packages (4)
ror40-rubygem-activerecord Red Hat:rhel_software_collections:1::el6All versions1:4.0.2-2.2.el6
ror40-rubygem-activerecord-doc Red Hat:rhel_software_collections:1::el6All versions1:4.0.2-2.2.el6
ror40-rubygem-activerecord Red Hat:rhel_software_collections:1::el7All versions1:4.0.2-2.2.el7
ror40-rubygem-activerecord-doc Red Hat:rhel_software_collections:1::el7All versions1:4.0.2-2.2.el7

Products include Rubyonrails Rails.

How do I fix CVE-2014-3483?

Upgrade activerecord to a fixed version for your release line: 4.0.7 or 4.1.3.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2014-3483 being exploited?

There is no known exploitation of CVE-2014-3483 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2014-3483, GHSA-r8fh-hq2p-7qhq, RHSA-2014:0877.

Is CVE-2014-3483 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free