# CVE-2014-3488: Denial of service in Netty

> Remote attackers can cause a denial of service via infinite loop and CPU consumption in Netty's SslHandler using crafted SSLv2Hello messages.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9959-6p3m-wxpc

## What is CVE-2014-3488?

CVE-2014-3488 is a medium-severity denial of service vulnerability in Netty Netty, published on 31 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2014-3488?

2 open source packages ship an affected version, including io.netty:netty-handler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler` | Maven | All versions | 3.9.2 |
| `io.netty:netty-handler` | Maven | All versions | 3.9.2 |

Products: Netty Netty.

## How do I fix CVE-2014-3488?

Upgrade io.netty:netty-handler to 3.9.2 or later.

## Is CVE-2014-3488 being exploited?

There is no known exploitation of CVE-2014-3488 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3488 and fix it if it is affected.

What it is: CVE-2014-3488 is a medium-severity denial of service vulnerability in Netty Netty, published on 31 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3488 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-handler (Maven): affected all versions; fixed in 3.9.2
- io.netty:netty-handler (Maven): affected all versions; fixed in 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3488/ (Markdown: https://insights.sbomify.com/CVE-2014-3488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3488
- OSV: https://osv.dev/vulnerability/CVE-2014-3488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3488/
Summaries are generated and may contain mistakes; the official description above is the record.
