{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-3494 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-3494 is a medium-severity vulnerability in Opensuse Opensuse, published on 1 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3494 and fix it if it is affected.\n\nWhat it is: CVE-2014-3494 is a medium-severity vulnerability in Opensuse Opensuse, published on 1 Jul 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3494 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3494/ (Markdown: https://insights.sbomify.com/CVE-2014-3494/index.md)","id":"CVE-2014-3494","markdown":"https://insights.sbomify.com/CVE-2014-3494/index.md","name":"CVE-2014-3494","record":{"aliases":["GHSA-rjp2-g39x-38r6","UBUNTU-CVE-2014-3494","openSUSE-SU-2024:10011-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"KDE libraries","requires_auth":"none","summary":"Man-in-the-middle attackers can obtain sensitive information via invalid certificates in the POP3 kioslave due to improper warning notifications.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kdelibs","vendor":"kde"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"kio/usernotificationhandler.cpp in the POP3 kioslave in kdelibs 4.10.95 before 4.13.3 does not properly generate warning notifications, which allows man-in-the-middle attackers to obtain sensitive information via an invalid certificate.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2014-3494","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"information_disclosure","year":"2014"},"n_packages":1,"n_references":4,"next":{"headline":"Security feature bypass in duplicity","id":"CVE-2014-3495"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.14.27-1.1"],"introduced":["0"],"last_affected":[],"package":"kdelibs4","purl":"pkg:rpm/opensuse/kdelibs4\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10011-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2014-3493"},"products":["n/a"],"published":"2014-07-01","related":[{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2009-2702","kev_date_added":null,"published":"2009-09-08"},{"cvss_score":7.5,"headline":"Command injection in n/a","id":"CVE-2004-1165","kev_date_added":null,"published":"2004-12-10"},{"cvss_score":5.5,"headline":"Information disclosure in n/a","id":"CVE-2017-6410","kev_date_added":null,"published":"2017-03-02"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2013-2074","kev_date_added":null,"published":"2014-02-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can obtain sensitive information via invalid certificates in the POP3 kioslave due to improper warning notifications.","url":"https://insights.sbomify.com/CVE-2014-3494/"}