{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3498 in the wild and no public exploit code.","fix":"Upgrade ansible to 1.6.6 or later.","what":"CVE-2014-3498 is a high-severity command injection vulnerability in n/a, published on 8 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3498 and fix it if it is affected.\n\nWhat it is: CVE-2014-3498 is a high-severity command injection vulnerability in n/a, published on 8 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3498 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 1.6.6\n- ansible (PyPI): affected all versions; fixed in 1.6.6\n- ansible (PyPI): affected all versions; fixed in 1.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3498/ (Markdown: https://insights.sbomify.com/CVE-2014-3498/index.md)","id":"CVE-2014-3498","markdown":"https://insights.sbomify.com/CVE-2014-3498/index.md","name":"CVE-2014-3498","record":{"aliases":["DEBIAN-CVE-2014-3498","GHSA-4cvm-5776-jx9f","PYSEC-2017-2","UBUNTU-CVE-2014-3498"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Remote authenticated users can execute arbitrary commands in Ansible, requiring an upgrade to secure the automation environment.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The user module in ansible before 1.6.6 allows remote authenticated users to execute arbitrary commands.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":3,"n_references":2,"next":{"headline":"Privilege Escalation in Docker","id":"CVE-2014-3499"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-4cvm-5776-jx9f"},{"ecosystem":"PyPI","fixed":["1.6.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-4cvm-5776-jx9f"},{"ecosystem":"PyPI","fixed":["1.6.6"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2017-2"}],"prev":{"headline":"OpenStack Swift Cross-site Scriping vulnerability","id":"CVE-2014-3497"},"products":["n/a"],"published":"2017-06-08","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated users can execute arbitrary commands in Ansible, requiring an upgrade to secure the automation environment.","url":"https://insights.sbomify.com/CVE-2014-3498/"}