# CVE-2014-3498: Ansible Arbitrary Code Execution

> Remote authenticated users can execute arbitrary commands in Ansible, requiring an upgrade to secure the automation environment.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3498, GHSA-4cvm-5776-jx9f, PYSEC-2017-2, UBUNTU-CVE-2014-3498

## What is CVE-2014-3498?

CVE-2014-3498 is a high-severity command injection vulnerability in n/a, published on 8 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The user module in ansible before 1.6.6 allows remote authenticated users to execute arbitrary commands.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-3498?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.6.6 |
| `ansible` | PyPI | All versions | 1.6.6 |
| `ansible` | PyPI | All versions | 1.6.6 |

Products: Redhat Ansible.

## How do I fix CVE-2014-3498?

Upgrade ansible to 1.6.6 or later.

## Is CVE-2014-3498 being exploited?

There is no known exploitation of CVE-2014-3498 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2017-7466](https://insights.sbomify.com/CVE-2017-7466/): Ansible Arbitrary Code Execution (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3498 and fix it if it is affected.

What it is: CVE-2014-3498 is a high-severity command injection vulnerability in n/a, published on 8 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3498 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.6.6
- ansible (PyPI): affected all versions; fixed in 1.6.6
- ansible (PyPI): affected all versions; fixed in 1.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3498/ (Markdown: https://insights.sbomify.com/CVE-2014-3498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3498
- OSV: https://osv.dev/vulnerability/CVE-2014-3498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3498/
Summaries are generated and may contain mistakes; the official description above is the record.
