{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2014-3504 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-3504 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 19 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3504 and fix it if it is affected.\n\nWhat it is: CVE-2014-3504 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 19 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3504 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3504/ (Markdown: https://insights.sbomify.com/CVE-2014-3504/index.md)","id":"CVE-2014-3504","markdown":"https://insights.sbomify.com/CVE-2014-3504/index.md","name":"CVE-2014-3504","record":{"aliases":["DEBIAN-CVE-2014-3504","GHSA-4425-mwr9-99xc","MGASA-2014-0353","UBUNTU-CVE-2014-3504","USN-2315-1","openSUSE-SU-2024:10569-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Serf SSL library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof SSL servers by exploiting improper NUL byte handling in certificate Common Name fields.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"subversion","vendor":"apache"},{"product":"ubuntu_linux","vendor":"canonical"},{"product":"serf","vendor":"serf_project"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:H/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[],"description":"The (1) serf_ssl_cert_issuer, (2) serf_ssl_cert_subject, and (3) serf_ssl_cert_certificate functions in Serf 0.2.0 through 1.3.x before 1.3.7 does not properly handle a NUL byte in a domain name in the subject's Common Name (CN) field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2014-3504","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"security_feature_bypass","year":"2014"},"n_packages":1,"n_references":9,"next":{"headline":"Use after free in n/a","id":"CVE-2014-3505"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.9-1.2"],"introduced":["0"],"last_affected":[],"package":"libserf","purl":"pkg:rpm/opensuse/libserf\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10569-1"}],"prev":{"headline":"Apache Syncope uses a weak PNRG","id":"CVE-2014-3503"},"products":["n/a"],"published":"2014-08-19","related":[{"cvss_score":9.8,"headline":"A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha","id":"CVE-2017-9800","kev_date_added":null,"published":"2017-08-11"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2013-4246","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5259","kev_date_added":null,"published":"2016-01-08"},{"cvss_score":8.2,"headline":"Apache Subversion: Command line argument injection on Windows platforms","id":"CVE-2024-45720","kev_date_added":null,"published":"2024-10-09"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2015-0202","kev_date_added":null,"published":"2015-04-08"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2013-2112","kev_date_added":null,"published":"2013-07-31"},{"cvss_score":7.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5343","kev_date_added":null,"published":"2016-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof SSL servers by exploiting improper NUL byte handling in certificate Common Name fields.","url":"https://insights.sbomify.com/CVE-2014-3504/"}