CVE-2014-3514 Active Record subject to strong parameters protection bypass

High 7.5 Published Updated

Remote attackers can bypass strong parameters protection in Ruby on Rails Active Record via crafted input to create_with calls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3514?

CVE-2014-3514 is a high-severity vulnerability in Rubyonrails Rails, published on 20 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

activerecord/lib/active_record/relation/query_methods.rb in Active Record in Ruby on Rails 4.0.x before 4.0.9 and 4.1.x before 4.1.5 allows remote attackers to bypass the strong parameters protection mechanism via crafted input to an application that makes create_with calls.

Weakness: CWE-264

Which versions are affected by CVE-2014-3514?

4 open source packages ship an affected version, including activerecord. It affects 1 product.

PackageAffectedFixed in
activerecord RubyGemsFrom 4.0.04.0.9
activerecord RubyGemsFrom 4.0.04.0.9
activerecord RubyGemsFrom 4.1.04.1.5
activerecord RubyGemsFrom 4.1.04.1.5
Linux distribution packages (5)
ror40-rubygem-activerecord Red Hat:rhel_software_collections:1::el6All versions1:4.0.2-2.3.el6
ror40-rubygem-activerecord-doc Red Hat:rhel_software_collections:1::el6All versions1:4.0.2-2.3.el6
ror40-rubygem-activerecord Red Hat:rhel_software_collections:1::el7All versions1:4.0.2-2.3.el7
ror40-rubygem-activerecord-doc Red Hat:rhel_software_collections:1::el7All versions1:4.0.2-2.3.el7
rubygem-railties-4_2 openSUSE:TumbleweedAll versions5.0.0.1-1.1

Products include Rubyonrails Rails.

How do I fix CVE-2014-3514?

Upgrade activerecord to a fixed version for your release line: 4.0.9 or 4.1.5.

Is CVE-2014-3514 being exploited?

There is no known exploitation of CVE-2014-3514 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2014-3514, GHSA-9rf5-jm6f-2fmm, RHSA-2014:1102, openSUSE-SU-2024:10207-1.

Is CVE-2014-3514 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free