# CVE-2014-3514: Active Record subject to strong parameters protection bypass

> Remote attackers can bypass strong parameters protection in Ruby on Rails Active Record via crafted input to create_with calls.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3514, GHSA-9rf5-jm6f-2fmm, RHSA-2014:1102, openSUSE-SU-2024:10207-1

## What is CVE-2014-3514?

CVE-2014-3514 is a high-severity vulnerability in Rubyonrails Rails, published on 20 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

activerecord/lib/active_record/relation/query_methods.rb in Active Record in Ruby on Rails 4.0.x before 4.0.9 and 4.1.x before 4.1.5 allows remote attackers to bypass the strong parameters protection mechanism via crafted input to an application that makes create_with calls.

Weakness: CWE-264

## Which versions are affected by CVE-2014-3514?

4 open source packages ship an affected version, including activerecord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 4.0.0 | 4.0.9 |
| `activerecord` | RubyGems | From 4.0.0 | 4.0.9 |
| `activerecord` | RubyGems | From 4.1.0 | 4.1.5 |
| `activerecord` | RubyGems | From 4.1.0 | 4.1.5 |
| `ror40-rubygem-activerecord` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:4.0.2-2.3.el6 |
| `ror40-rubygem-activerecord-doc` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:4.0.2-2.3.el6 |
| `ror40-rubygem-activerecord` | Red Hat:rhel_software_collections:1::el7 | All versions | 1:4.0.2-2.3.el7 |
| `ror40-rubygem-activerecord-doc` | Red Hat:rhel_software_collections:1::el7 | All versions | 1:4.0.2-2.3.el7 |
| `rubygem-railties-4_2` | openSUSE:Tumbleweed | All versions | 5.0.0.1-1.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2014-3514?

Upgrade activerecord to a fixed version for your release line: 4.0.9 or 4.1.5.

## Is CVE-2014-3514 being exploited?

There is no known exploitation of CVE-2014-3514 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3514 and fix it if it is affected.

What it is: CVE-2014-3514 is a high-severity vulnerability in Rubyonrails Rails, published on 20 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3514 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.0.9
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.0.9
- activerecord (RubyGems): affected from 4.1.0; fixed in 4.1.5
- activerecord (RubyGems): affected from 4.1.0; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3514/ (Markdown: https://insights.sbomify.com/CVE-2014-3514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3514
- OSV: https://osv.dev/vulnerability/CVE-2014-3514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3514/
Summaries are generated and may contain mistakes; the official description above is the record.
