# CVE-2014-3517: OpenStack Compute (Nova) Exposure of Sensitive Information to an Unauthorized Actor vulnerability

> Remote attackers can brute-force instance ID signatures via timing differences in metadata requests, potentially exposing sensitive instance information.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3517, GHSA-xjmj-p278-4jp5, PYSEC-2026-884, RHSA-2014:0940, UBUNTU-CVE-2014-3517, USN-2325-1

## What is CVE-2014-3517?

CVE-2014-3517 is a medium-severity vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

api/metadata/handler.py in OpenStack Compute (Nova) before 2013.2.4, 2014.x before 2014.1.2, and Juno before Juno-2, when proxying metadata requests through Neutron, makes it easier for remote attackers to guess instance ID signatures via a brute-force attack that relies on timing differences in responses to instance metadata requests.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-3517?

5 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 2013.2.4, 2014.1.2 |
| `nova` | PyPI | All versions | 2013.2.4 |
| `nova` | PyPI | All versions | 2013.2.4 |
| `nova` | PyPI | From 2014.0.0 | 2014.1.2 |
| `nova` | PyPI | From 2014.0.0 | 2014.1.2 |
| `openstack-nova` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-api` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-cells` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-cert` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-common` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-compute` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-conductor` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-console` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-network` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-novncproxy` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-objectstore` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `openstack-nova-scheduler` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |
| `python-nova` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.1-4.el7ost |

Products: Openstack Nova.

## How do I fix CVE-2014-3517?

Upgrade nova to a fixed version for your release line: 2013.2.4 or 2014.1.2.

## Is CVE-2014-3517 being exploited?

There is no known exploitation of CVE-2014-3517 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3517 and fix it if it is affected.

What it is: CVE-2014-3517 is a medium-severity vulnerability in n/a, published on 7 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3517 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 2013.2.4, 2014.1.2
- nova (PyPI): affected all versions; fixed in 2013.2.4
- nova (PyPI): affected all versions; fixed in 2013.2.4
- nova (PyPI): affected from 2014.0.0; fixed in 2014.1.2
- nova (PyPI): affected from 2014.0.0; fixed in 2014.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3517/ (Markdown: https://insights.sbomify.com/CVE-2014-3517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3517
- OSV: https://osv.dev/vulnerability/CVE-2014-3517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3517/
Summaries are generated and may contain mistakes; the official description above is the record.
