CVE-2014-3526 Apache Wicket Sensitive Data Exposure

High 7.5 Published Updated

Remote attackers can obtain sensitive information via session identifiers in Apache Wicket, requiring an upgrade to secure the application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3526?

CVE-2014-3526 is a high-severity vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.

Weakness: CWE-200

Which versions are affected by CVE-2014-3526?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.

PackageAffectedFixed in
org.apache.wicket:wicket-core MavenAll versions1.5.12
org.apache.wicket:wicket-core MavenAll versions1.5.12
org.apache.wicket:wicket-core MavenFrom 6.06.17.0
org.apache.wicket:wicket-core MavenFrom 6.06.17.0
org.apache.wicket:wicket-core MavenFrom 7.0.0-M17.0.0-M3
org.apache.wicket:wicket-core MavenFrom 7.0.0-M17.0.0-M3

Products include Apache Wicket.

How do I fix CVE-2014-3526?

Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 1.5.12, 6.17.0 or 7.0.0-M3.

Is CVE-2014-3526 being exploited?

There is no known exploitation of CVE-2014-3526 in the wild and no public exploit code.

Sources

Also known as GHSA-q7wx-mhx4-jr8q.

Is CVE-2014-3526 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free