{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3526 in the wild and no public exploit code.","fix":"Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 1.5.12, 6.17.0 or 7.0.0-M3.","what":"CVE-2014-3526 is a high-severity vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3526 and fix it if it is affected.\n\nWhat it is: CVE-2014-3526 is a high-severity vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3526 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 1.5.12\n- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 1.5.12\n- org.apache.wicket:wicket-core (Maven): affected from 6.0; fixed in 6.17.0\n- org.apache.wicket:wicket-core (Maven): affected from 6.0; fixed in 6.17.0\n- org.apache.wicket:wicket-core (Maven): affected from 7.0.0-M1; fixed in 7.0.0-M3\n- org.apache.wicket:wicket-core (Maven): affected from 7.0.0-M1; fixed in 7.0.0-M3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3526/ (Markdown: https://insights.sbomify.com/CVE-2014-3526/index.md)","id":"CVE-2014-3526","markdown":"https://insights.sbomify.com/CVE-2014-3526/index.md","name":"CVE-2014-3526","record":{"aliases":["GHSA-q7wx-mhx4-jr8q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can obtain sensitive information via session identifiers in Apache Wicket, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"wicket","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Wicket Sensitive Data Exposure","id":"CVE-2014-3526","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":6,"n_references":1,"next":{"headline":"Authorization Bypass in Spring Security","id":"CVE-2014-3527"},"packages":[{"ecosystem":"Maven","fixed":["1.5.12"],"introduced":["0"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":null,"source":"GHSA-q7wx-mhx4-jr8q"},{"ecosystem":"Maven","fixed":["1.5.12"],"introduced":["0"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":"pkg:maven/org.apache.wicket/wicket-core","source":"GHSA-q7wx-mhx4-jr8q"},{"ecosystem":"Maven","fixed":["6.17.0"],"introduced":["6.0"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":null,"source":"GHSA-q7wx-mhx4-jr8q"},{"ecosystem":"Maven","fixed":["6.17.0"],"introduced":["6.0"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":"pkg:maven/org.apache.wicket/wicket-core","source":"GHSA-q7wx-mhx4-jr8q"},{"ecosystem":"Maven","fixed":["7.0.0-M3"],"introduced":["7.0.0-M1"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":null,"source":"GHSA-q7wx-mhx4-jr8q"},{"ecosystem":"Maven","fixed":["7.0.0-M3"],"introduced":["7.0.0-M1"],"last_affected":[],"package":"org.apache.wicket:wicket-core","purl":"pkg:maven/org.apache.wicket/wicket-core","source":"GHSA-q7wx-mhx4-jr8q"}],"prev":{"headline":"Other in n/a","id":"CVE-2014-3525"},"products":["n/a"],"published":"2017-10-30","related":[{"cvss_score":9.8,"headline":"Apache Wicket: Remote code execution via XSLT injection","id":"CVE-2024-36522","kev_date_added":null,"published":"2024-07-12"},{"cvss_score":9.1,"headline":"Apache Wicket: possible session fixation using AuthenticatedWebSession","id":"CVE-2026-40010","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":9.1,"headline":"Deserialization in n/a","id":"CVE-2016-6793","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache Wicket vulnerable to CSRF attacks","id":"CVE-2016-6806","kev_date_added":null,"published":"2017-10-02"},{"cvss_score":7.5,"headline":"Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed","id":"CVE-2026-71257","kev_date_added":null,"published":"2026-08-31"},{"cvss_score":7.5,"headline":"Apache Wicket: crafted URLs can bypass PackageResourceGuard","id":"CVE-2026-43646","kev_date_added":null,"published":"2026-05-06"},{"cvss_score":7.5,"headline":"DNS proxy and possible amplification attack","id":"CVE-2021-23937","kev_date_added":null,"published":"2021-05-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information via session identifiers in Apache Wicket, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2014-3526/"}