{"answers":{"affected":"3 open source packages ship an affected version, including rope. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3539 in the wild and no public exploit code.","fix":"Upgrade rope to 0.11.0 or later.","what":"CVE-2014-3539 is a critical unsafe deserialization vulnerability in n/a, published on 6 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3539 and fix it if it is affected.\n\nWhat it is: CVE-2014-3539 is a critical unsafe deserialization vulnerability in n/a, published on 6 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3539 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rope (PyPI): affected all versions; fixed in 0.11.0\n- rope (PyPI): affected all versions; fixed in 0.11.0\n- rope (PyPI): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3539/ (Markdown: https://insights.sbomify.com/CVE-2014-3539/index.md)","id":"CVE-2014-3539","markdown":"https://insights.sbomify.com/CVE-2014-3539/index.md","name":"CVE-2014-3539","record":{"aliases":["DEBIAN-CVE-2014-3539","GHSA-r38r-qp28-2m63","MGASA-2015-0122","PYSEC-2018-100","UBUNTU-CVE-2014-3539","openSUSE-SU-2024:10052-1","openSUSE-SU-2024:11267-1","openSUSE-SU-2024:14161-1","openSUSE-SU-2026:12039-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Rope library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via unsafe pickle deserialization in the Rope library's DOA module.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rope","vendor":"rope_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"base/oi/doa.py in the Rope library in CPython (aka Python) allows remote attackers to execute arbitrary code by leveraging an unsafe call to pickle.load.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in rope","id":"CVE-2014-3539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2014"},"n_packages":7,"n_references":2,"next":{"headline":"Moodle vulnerable to PHP object injection attacks","id":"CVE-2014-3541"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"rope","purl":null,"source":"GHSA-r38r-qp28-2m63"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"rope","purl":"pkg:pypi/rope","source":"GHSA-r38r-qp28-2m63"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"rope","purl":"pkg:pypi/rope","source":"PYSEC-2018-100"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.10.2-2.2"],"introduced":["0"],"last_affected":[],"package":"python-rope","purl":"pkg:rpm/opensuse/python-rope\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10052-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.19.0-1.3"],"introduced":["0"],"last_affected":[],"package":"python-rope","purl":"pkg:rpm/opensuse/python-rope\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11267-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.12.0-1.3"],"introduced":["0"],"last_affected":[],"package":"python-rope","purl":"pkg:rpm/opensuse/python-rope\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14161-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.14.0-1.4"],"introduced":["0"],"last_affected":[],"package":"python-rope","purl":"pkg:rpm/opensuse/python-rope\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12039-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2014-3538"},"products":["n/a"],"published":"2018-04-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via unsafe pickle deserialization in the Rope library's DOA module.","url":"https://insights.sbomify.com/CVE-2014-3539/"}