CVE-2014-3543 Moodle Arbitrary File Read via XML External Entity vulnerability
Remote attackers can read arbitrary files on Moodle servers by uploading malicious IMSCP/IMSCC packages containing XML External Entity declarations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-3543?
CVE-2014-3543 is a medium-severity vulnerability in Moodle Moodle, published on 29 Jul 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
mod/imscp/locallib.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via a package with a manifest file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue affecting IMSCP resources and the IMSCC format.
Weakness: CWE-200
Which versions are affected by CVE-2014-3543?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.11 |
moodle/moodle Packagist | All versions | 2.4.11 |
moodle/moodle Packagist | From 2.5.0 | 2.5.7 |
moodle/moodle Packagist | From 2.5.0 | 2.5.7 |
moodle/moodle Packagist | From 2.6.0 | 2.6.4 |
moodle/moodle Packagist | From 2.6.0 | 2.6.4 |
2 more packages
moodle/moodle Packagist | From 2.7.0 | 2.7.1 |
moodle/moodle Packagist | From 2.7.0 | 2.7.1 |
Products include Moodle Moodle.
How do I fix CVE-2014-3543?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.11, 2.5.7, 2.6.4 or 2.7.1.
Is CVE-2014-3543 being exploited?
There is no known exploitation of CVE-2014-3543 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-27j2-c838-c3qg.