CVE-2014-3544 Moodle cross-site scripting (XSS) vulnerability
Authenticated users can inject scripts via the Skype ID field, potentially stealing session data or taking over accounts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-3544?
CVE-2014-3544 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in user/profile.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via the Skype ID profile field.
Weakness: CWE-79
Which versions are affected by CVE-2014-3544?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.11 |
moodle/moodle Packagist | All versions | 2.4.11 |
moodle/moodle Packagist | From 2.5.0 | 2.5.7 |
moodle/moodle Packagist | From 2.5.0 | 2.5.7 |
moodle/moodle Packagist | From 2.6.0 | 2.6.4 |
moodle/moodle Packagist | From 2.6.0 | 2.6.4 |
2 more packages
moodle/moodle Packagist | From 2.7.0 | 2.7.1 |
moodle/moodle Packagist | From 2.7.0 | 2.7.1 |
Products include Moodle Moodle.
How do I fix CVE-2014-3544?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.11, 2.5.7, 2.6.4 or 2.7.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-3544 being exploited?
There is no known exploitation of CVE-2014-3544 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-c9jp-244j-vh78.