# CVE-2014-3546: Moodle allows attackers to obtain username and course information

> Remote attackers can access sensitive username and course information by bypassing capability checks in Moodle notes and user editing pages.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4c5g-w3gf-rf4f

## What is CVE-2014-3546?

CVE-2014-3546 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce certain capability requirements in (1) notes/index.php and (2) user/edit.php, which allows remote attackers to obtain potentially sensitive username and course information via a modified URL.

Weakness: CWE-264

## Which versions are affected by CVE-2014-3546?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 2.4.11 |
| `moodle/moodle` | Packagist | All versions | 2.4.11 |
| `moodle/moodle` | Packagist | From 2.5.0 | 2.5.7 |
| `moodle/moodle` | Packagist | From 2.5.0 | 2.5.7 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.4 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.4 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.1 |
| `moodle/moodle` | Packagist | From 2.7.0 | 2.7.1 |

Products: Moodle Moodle.

## How do I fix CVE-2014-3546?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.11, 2.5.7, 2.6.4 or 2.7.1.

## Is CVE-2014-3546 being exploited?

There is no known exploitation of CVE-2014-3546 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3546 and fix it if it is affected.

What it is: CVE-2014-3546 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3546 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 2.4.11
- moodle/moodle (Packagist): affected all versions; fixed in 2.4.11
- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.7
- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.7
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.4
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.4
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.1
- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3546/ (Markdown: https://insights.sbomify.com/CVE-2014-3546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3546
- OSV: https://osv.dev/vulnerability/CVE-2014-3546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3546/
Summaries are generated and may contain mistakes; the official description above is the record.
