CVE-2014-3547 Moodle multiple cross-site scripting (XSS) vulnerabilities

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via external badges in Moodle, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-3547?

CVE-2014-3547 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in badges/renderer.php in Moodle 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via an external badge.

Weakness: CWE-79

Which versions are affected by CVE-2014-3547?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.5.02.5.7
moodle/moodle PackagistFrom 2.5.02.5.7
moodle/moodle PackagistFrom 2.6.02.6.4
moodle/moodle PackagistFrom 2.6.02.6.4
moodle/moodle PackagistFrom 2.7.02.7.1
moodle/moodle PackagistFrom 2.7.02.7.1

Products include Moodle Moodle.

How do I fix CVE-2014-3547?

Upgrade moodle/moodle to a fixed version for your release line: 2.5.7, 2.6.4 or 2.7.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-3547 being exploited?

There is no known exploitation of CVE-2014-3547 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-hwjv-mc78-cccj.

Is CVE-2014-3547 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free