{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3551 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.4.11, 2.5.7, 2.6.4 or 2.7.1.","what":"CVE-2014-3551 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3551 and fix it if it is affected.\n\nWhat it is: CVE-2014-3551 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Jul 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3551 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 2.4.11\n- moodle/moodle (Packagist): affected all versions; fixed in 2.4.11\n- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.7\n- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.7\n- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.4\n- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.4\n- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.1\n- moodle/moodle (Packagist): affected from 2.7.0; fixed in 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3551/ (Markdown: https://insights.sbomify.com/CVE-2014-3551/index.md)","id":"CVE-2014-3551","markdown":"https://insights.sbomify.com/CVE-2014-3551/index.md","name":"CVE-2014-3551","record":{"aliases":["GHSA-m8f5-9wg8-2c3h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Authenticated users can inject malicious scripts via rubric fields in Moodle's advanced grading, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the advanced-grading implementation in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) qualification or (2) rating field in a rubric.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2021-01-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-01-27T01:02:49Z","kind":"github_poc","ref":"https://github.com/JavaGarcia/CVE-2014-3551","stars":0,"title":"CVE-2014-3551"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Moodle multiple cross-site scripting (XSS) vulnerabilities","id":"CVE-2014-3551","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2014"},"n_packages":8,"n_references":4,"next":{"headline":"Auth bypass in n/a","id":"CVE-2014-3552"},"packages":[{"ecosystem":"Packagist","fixed":["2.4.11"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.4.11"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["2.5.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["2.5.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.7.1"],"introduced":["2.7.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m8f5-9wg8-2c3h"},{"ecosystem":"Packagist","fixed":["2.7.1"],"introduced":["2.7.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m8f5-9wg8-2c3h"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-3550"},"products":["n/a"],"published":"2014-07-29","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject malicious scripts via rubric fields in Moodle's advanced grading, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2014-3551/"}