CVE-2014-3574 Improper Input Validation in Apache POI

Medium 4.3 Published Updated

Remote attackers can cause denial of service via crafted OOXML files in Apache POI, requiring user interaction to open the file.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-3574?

CVE-2014-3574 is a medium-severity vulnerability in n/a, published on 4 Sep 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

Which versions are affected by CVE-2014-3574?

4 open source packages ship an affected version, including org.apache.poi:poi. It affects 1 product.

PackageAffectedFixed in
org.apache.poi:poi MavenAll versions3.10.1
org.apache.poi:poi MavenAll versions3.10.1
org.apache.poi:poi MavenFrom 3.11-beta13.11-beta2
org.apache.poi:poi MavenFrom 3.11-beta13.11-beta2

Products include Apache Poi.

How do I fix CVE-2014-3574?

Upgrade org.apache.poi:poi to a fixed version for your release line: 3.10.1 or 3.11-beta2.

Is CVE-2014-3574 being exploited?

There is no known exploitation of CVE-2014-3574 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2014-3574, GHSA-5wfp-8643-c58x.

Is CVE-2014-3574 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free