{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.poi:poi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3574 in the wild and no public exploit code.","fix":"Upgrade org.apache.poi:poi to a fixed version for your release line: 3.10.1 or 3.11-beta2.","what":"CVE-2014-3574 is a medium-severity vulnerability in n/a, published on 4 Sep 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3574 and fix it if it is affected.\n\nWhat it is: CVE-2014-3574 is a medium-severity vulnerability in n/a, published on 4 Sep 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3574 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.10.1\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.10.1\n- org.apache.poi:poi (Maven): affected from 3.11-beta1; fixed in 3.11-beta2\n- org.apache.poi:poi (Maven): affected from 3.11-beta1; fixed in 3.11-beta2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3574/ (Markdown: https://insights.sbomify.com/CVE-2014-3574/index.md)","id":"CVE-2014-3574","markdown":"https://insights.sbomify.com/CVE-2014-3574/index.md","name":"CVE-2014-3574","record":{"aliases":["DEBIAN-CVE-2014-3574","GHSA-5wfp-8643-c58x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java Office library","requires_auth":"none","summary":"Remote attackers can cause denial of service via crafted OOXML files in Apache POI, requiring user interaction to open the file.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"poi","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Apache POI","id":"CVE-2014-3574","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":4,"n_references":13,"next":{"headline":"Information disclosure in n/a","id":"CVE-2014-3575"},"packages":[{"ecosystem":"Maven","fixed":["3.10.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":null,"source":"GHSA-5wfp-8643-c58x"},{"ecosystem":"Maven","fixed":["3.10.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","source":"GHSA-5wfp-8643-c58x"},{"ecosystem":"Maven","fixed":["3.11-beta2"],"introduced":["3.11-beta1"],"last_affected":[],"package":"org.apache.poi:poi","purl":null,"source":"GHSA-5wfp-8643-c58x"},{"ecosystem":"Maven","fixed":["3.11-beta2"],"introduced":["3.11-beta1"],"last_affected":[],"package":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","source":"GHSA-5wfp-8643-c58x"}],"prev":{"headline":"XML external entity in n/a","id":"CVE-2014-3573"},"products":["n/a"],"published":"2014-09-04","related":[{"cvss_score":7.5,"headline":"Denial of Service in Apache POI","id":"CVE-2017-12626","kev_date_added":null,"published":"2018-01-29"},{"cvss_score":5.5,"headline":"A carefully crafted TNEF file can cause an out of memory exception","id":"CVE-2022-26336","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":5.5,"headline":"Improper Restriction of XML External Entity Reference in Apache POI","id":"CVE-2019-12415","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":5.5,"headline":"Improper Restriction of Recursive Entity References in DTDs in Apache POI","id":"CVE-2017-5644","kev_date_added":null,"published":"2017-03-24"},{"cvss_score":5.5,"headline":"Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability","id":"CVE-2016-5000","kev_date_added":null,"published":"2016-08-05"},{"cvss_score":5.3,"headline":"Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing","id":"CVE-2025-31672","kev_date_added":null,"published":"2025-04-09"},{"cvss_score":5,"headline":"Loop with Unreachable Exit Condition in Apache POI","id":"CVE-2014-9527","kev_date_added":null,"published":"2015-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via crafted OOXML files in Apache POI, requiring user interaction to open the file.","url":"https://insights.sbomify.com/CVE-2014-3574/"}