{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.activemq:apollo-project. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3579 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:apollo-project to 1.7.1 or later.","what":"CVE-2014-3579 is a critical vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3579 and fix it if it is affected.\n\nWhat it is: CVE-2014-3579 is a critical vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3579 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:apollo-project (Maven): affected from 1.0.0; fixed in 1.7.1\n- org.apache.activemq:apollo-project (Maven): affected from 1.0.0; fixed in 1.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3579/ (Markdown: https://insights.sbomify.com/CVE-2014-3579/index.md)","id":"CVE-2014-3579","markdown":"https://insights.sbomify.com/CVE-2014-3579/index.md","name":"CVE-2014-3579","record":{"aliases":["GHSA-wmhw-hpwh-44pg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Message broker","requires_auth":"none","summary":"Remote attackers can exploit an XML external entity vulnerability in Apache ActiveMQ Apollo via XPath selectors, potentially reading data or causing denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq_apollo","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"XML external entity (XXE) vulnerability in Apache ActiveMQ Apollo 1.x before 1.7.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ActiveMQ Apollo XXE Vulnerability","id":"CVE-2014-3579","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"Null dereference in n/a","id":"CVE-2014-3580"},"packages":[{"ecosystem":"Maven","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.activemq:apollo-project","purl":null,"source":"GHSA-wmhw-hpwh-44pg"},{"ecosystem":"Maven","fixed":["1.7.1"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.activemq:apollo-project","purl":"pkg:maven/org.apache.activemq/apollo-project","source":"GHSA-wmhw-hpwh-44pg"}],"prev":{"headline":"Improper Limitation of a Pathname to a Restricted Directory in Spring Framework","id":"CVE-2014-3578"},"products":["n/a"],"published":"2017-10-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit an XML external entity vulnerability in Apache ActiveMQ Apollo via XPath selectors, potentially reading data or causing denial of service.","url":"https://insights.sbomify.com/CVE-2014-3579/"}