# CVE-2014-3579: Apache ActiveMQ Apollo XXE Vulnerability

> Remote attackers can exploit an XML external entity vulnerability in Apache ActiveMQ Apollo via XPath selectors, potentially reading data or causing denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wmhw-hpwh-44pg

## What is CVE-2014-3579?

CVE-2014-3579 is a critical vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XML external entity (XXE) vulnerability in Apache ActiveMQ Apollo 1.x before 1.7.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2014-3579?

2 open source packages ship an affected version, including org.apache.activemq:apollo-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:apollo-project` | Maven | From 1.0.0 | 1.7.1 |
| `org.apache.activemq:apollo-project` | Maven | From 1.0.0 | 1.7.1 |

Products: Apache Activemq Apollo.

## How do I fix CVE-2014-3579?

Upgrade org.apache.activemq:apollo-project to 1.7.1 or later.

## Is CVE-2014-3579 being exploited?

There is no known exploitation of CVE-2014-3579 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3579 and fix it if it is affected.

What it is: CVE-2014-3579 is a critical vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3579 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:apollo-project (Maven): affected from 1.0.0; fixed in 1.7.1
- org.apache.activemq:apollo-project (Maven): affected from 1.0.0; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3579/ (Markdown: https://insights.sbomify.com/CVE-2014-3579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3579
- OSV: https://osv.dev/vulnerability/CVE-2014-3579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3579/
Summaries are generated and may contain mistakes; the official description above is the record.
