CVE-2014-3589 Pillow denial of service via Crafted Block Size
Remote attackers can cause a denial of service in PIL and Pillow by submitting a crafted image with a malicious block size.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-3589?
CVE-2014-3589 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 25 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
Weakness: CWE-20
Which versions are affected by CVE-2014-3589?
5 open source packages ship an affected version, including pillow. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
pillow PyPI | All versions | 2.3.2, 2.5.2 |
pillow PyPI | All versions | 2.3.2 |
pillow PyPI | All versions | 2.3.2 |
pillow PyPI | From 2.5 | 2.5.2 |
pillow PyPI | From 2.5 | 2.5.2 |
Products include Debian Python-Imaging, Opensuse Opensuse, Python Pillow.
How do I fix CVE-2014-3589?
Upgrade pillow to a fixed version for your release line: 2.3.2 or 2.5.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2014-3589 being exploited?
There is no known exploitation of CVE-2014-3589 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2014-3589, DLA-41-1, DSA-3009-1, GHSA-cfmr-38g9-f2h7, MGASA-2014-0343, PYSEC-2014-10 and 1 more.