{"answers":{"affected":"5 open source packages ship an affected version, including pillow. It affects 3 products.","exploited":"There is no known exploitation of CVE-2014-3589 in the wild and no public exploit code.","fix":"Upgrade pillow to a fixed version for your release line: 2.3.2 or 2.5.2.","what":"CVE-2014-3589 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 25 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3589 and fix it if it is affected.\n\nWhat it is: CVE-2014-3589 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 25 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3589 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pillow (PyPI): affected all versions; fixed in 2.3.2, 2.5.2\n- pillow (PyPI): affected all versions; fixed in 2.3.2\n- pillow (PyPI): affected all versions; fixed in 2.3.2\n- pillow (PyPI): affected from 2.5; fixed in 2.5.2\n- pillow (PyPI): affected from 2.5; fixed in 2.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3589/ (Markdown: https://insights.sbomify.com/CVE-2014-3589/index.md)","id":"CVE-2014-3589","markdown":"https://insights.sbomify.com/CVE-2014-3589/index.md","name":"CVE-2014-3589","record":{"aliases":["DEBIAN-CVE-2014-3589","DLA-41-1","DSA-3009-1","GHSA-cfmr-38g9-f2h7","MGASA-2014-0343","PYSEC-2014-10","UBUNTU-CVE-2014-3589"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Imaging Library","requires_auth":"none","summary":"Remote attackers can cause a denial of service in PIL and Pillow by submitting a crafted image with a malicious block size.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"python-imaging","vendor":"debian"},{"product":"opensuse","vendor":"opensuse"},{"product":"pillow","vendor":"python"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pillow denial of service via Crafted Block Size","id":"CVE-2014-3589","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse","python:pillow"],"type":"denial_of_service","year":"2014"},"n_packages":5,"n_references":6,"next":{"headline":"Cross-site request forgery in Red Hat Satellite 6","id":"CVE-2014-3590"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.2","2.5.2"],"introduced":["0","2.5"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"PYSEC-2014-10"},{"ecosystem":"PyPI","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":null,"source":"GHSA-cfmr-38g9-f2h7"},{"ecosystem":"PyPI","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"GHSA-cfmr-38g9-f2h7"},{"ecosystem":"PyPI","fixed":["2.5.2"],"introduced":["2.5"],"last_affected":[],"package":"pillow","purl":null,"source":"GHSA-cfmr-38g9-f2h7"},{"ecosystem":"PyPI","fixed":["2.5.2"],"introduced":["2.5"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"GHSA-cfmr-38g9-f2h7"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2014-3588"},"products":["n/a"],"published":"2014-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in PIL and Pillow by submitting a crafted image with a malicious block size.","url":"https://insights.sbomify.com/CVE-2014-3589/"}