# CVE-2014-3589: Pillow denial of service via Crafted Block Size

> Remote attackers can cause a denial of service in PIL and Pillow by submitting a crafted image with a malicious block size.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3589, DLA-41-1, DSA-3009-1, GHSA-cfmr-38g9-f2h7, MGASA-2014-0343, PYSEC-2014-10, UBUNTU-CVE-2014-3589

## What is CVE-2014-3589?

CVE-2014-3589 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 25 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-3589?

5 open source packages ship an affected version, including pillow. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 2.3.2, 2.5.2 |
| `pillow` | PyPI | All versions | 2.3.2 |
| `pillow` | PyPI | All versions | 2.3.2 |
| `pillow` | PyPI | From 2.5 | 2.5.2 |
| `pillow` | PyPI | From 2.5 | 2.5.2 |

Products: Debian Python-Imaging, Opensuse Opensuse, Python Pillow.

## How do I fix CVE-2014-3589?

Upgrade pillow to a fixed version for your release line: 2.3.2 or 2.5.2.

## Is CVE-2014-3589 being exploited?

There is no known exploitation of CVE-2014-3589 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3589 and fix it if it is affected.

What it is: CVE-2014-3589 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 25 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3589 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 2.3.2, 2.5.2
- pillow (PyPI): affected all versions; fixed in 2.3.2
- pillow (PyPI): affected all versions; fixed in 2.3.2
- pillow (PyPI): affected from 2.5; fixed in 2.5.2
- pillow (PyPI): affected from 2.5; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3589/ (Markdown: https://insights.sbomify.com/CVE-2014-3589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3589
- OSV: https://osv.dev/vulnerability/CVE-2014-3589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3589/
Summaries are generated and may contain mistakes; the official description above is the record.
