{"answers":{"affected":"3 open source packages ship an affected version, including pillow. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-3598 in the wild and no public exploit code.","fix":"Upgrade pillow to 2.5.3 or later.","what":"CVE-2014-3598 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 1 May 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3598 and fix it if it is affected.\n\nWhat it is: CVE-2014-3598 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 1 May 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3598 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pillow (PyPI): affected all versions; fixed in 2.5.3\n- pillow (PyPI): affected all versions; fixed in 2.5.3\n- pillow (PyPI): affected all versions; fixed in 2.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3598/ (Markdown: https://insights.sbomify.com/CVE-2014-3598/index.md)","id":"CVE-2014-3598","markdown":"https://insights.sbomify.com/CVE-2014-3598/index.md","name":"CVE-2014-3598","record":{"aliases":["DEBIAN-CVE-2014-3598","GHSA-j6f7-g425-4gmx","PYSEC-2015-15"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python image library","requires_auth":"none","summary":"Remote attackers can cause a denial of service in Pillow by tricking users into opening a crafted JPEG2000 image.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"pillow","vendor":"python"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pillow is vulnerable to Denial of Service (DOS) in the Jpeg2KImagePlugin","id":"CVE-2014-3598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse","python:pillow"],"type":"denial_of_service","year":"2014"},"n_packages":3,"n_references":2,"next":{"headline":"HornetQ REST vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2014-3599"},"packages":[{"ecosystem":"PyPI","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":null,"source":"GHSA-j6f7-g425-4gmx"},{"ecosystem":"PyPI","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"GHSA-j6f7-g425-4gmx"},{"ecosystem":"PyPI","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"pillow","purl":"pkg:pypi/pillow","source":"PYSEC-2015-15"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2014-3597"},"products":["n/a"],"published":"2015-05-01","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in Pillow by tricking users into opening a crafted JPEG2000 image.","url":"https://insights.sbomify.com/CVE-2014-3598/"}