{"answers":{"affected":"2 open source packages ship an affected version, including org.hornetq.rest:hornetq-rest. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3599 in the wild and no public exploit code.","fix":"Upgrade org.hornetq.rest:hornetq-rest to 2.5.0.Beta1 or later.","what":"CVE-2014-3599 is a medium-severity vulnerability in HornetQ REST, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-3599 and fix it if it is affected.\n\nWhat it is: CVE-2014-3599 is a medium-severity vulnerability in HornetQ REST, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-3599 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.hornetq.rest:hornetq-rest (Maven): affected all versions; fixed in 2.5.0.Beta1\n- org.hornetq.rest:hornetq-rest (Maven): affected all versions; fixed in 2.5.0.Beta1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3599/ (Markdown: https://insights.sbomify.com/CVE-2014-3599/index.md)","id":"CVE-2014-3599","markdown":"https://insights.sbomify.com/CVE-2014-3599/index.md","name":"CVE-2014-3599","record":{"aliases":["GHSA-xrh2-c3rm-35jr"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HornetQ REST","requires_auth":"none","summary":"An XML External Entity vulnerability in HornetQ REST allows attackers to read sensitive files or cause denial of service via crafted XML input.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"hornetq","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"HornetQ REST is vulnerable to XML External Entity due to insecure configuration of RestEasy","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HornetQ REST vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2014-3599","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600"},"packages":[{"ecosystem":"Maven","fixed":["2.5.0.Beta1"],"introduced":["0"],"last_affected":[],"package":"org.hornetq.rest:hornetq-rest","purl":null,"source":"GHSA-xrh2-c3rm-35jr"},{"ecosystem":"Maven","fixed":["2.5.0.Beta1"],"introduced":["0"],"last_affected":[],"package":"org.hornetq.rest:hornetq-rest","purl":"pkg:maven/org.hornetq.rest/hornetq-rest","source":"GHSA-xrh2-c3rm-35jr"}],"prev":{"headline":"Pillow is vulnerable to Denial of Service (DOS) in the Jpeg2KImagePlugin","id":"CVE-2014-3598"},"products":["HornetQ REST"],"published":"2019-11-12","related":[{"cvss_score":9.1,"headline":"hornetq vulnerable to file overwrite, sensitive information disclosure","id":"CVE-2024-51127","kev_date_added":null,"published":"2024-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["HornetQ REST"]},"summary":"An XML External Entity vulnerability in HornetQ REST allows attackers to read sensitive files or cause denial of service via crafted XML input.","url":"https://insights.sbomify.com/CVE-2014-3599/"}