# CVE-2014-3599: HornetQ REST vulnerable to Improper Restriction of XML External Entity Reference

> An XML External Entity vulnerability in HornetQ REST allows attackers to read sensitive files or cause denial of service via crafted XML input.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xrh2-c3rm-35jr

## What is CVE-2014-3599?

CVE-2014-3599 is a medium-severity vulnerability in HornetQ REST, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HornetQ REST is vulnerable to XML External Entity due to insecure configuration of RestEasy

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2014-3599?

2 open source packages ship an affected version, including org.hornetq.rest:hornetq-rest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.hornetq.rest:hornetq-rest` | Maven | All versions | 2.5.0.Beta1 |
| `org.hornetq.rest:hornetq-rest` | Maven | All versions | 2.5.0.Beta1 |

Products: Redhat Hornetq.

## How do I fix CVE-2014-3599?

Upgrade org.hornetq.rest:hornetq-rest to 2.5.0.Beta1 or later.

## Is CVE-2014-3599 being exploited?

There is no known exploitation of CVE-2014-3599 in the wild and no public exploit code.

## Other vulnerabilities in HornetQ REST

- [CVE-2024-51127](https://insights.sbomify.com/CVE-2024-51127/): hornetq vulnerable to file overwrite, sensitive information disclosure (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3599 and fix it if it is affected.

What it is: CVE-2014-3599 is a medium-severity vulnerability in HornetQ REST, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3599 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.hornetq.rest:hornetq-rest (Maven): affected all versions; fixed in 2.5.0.Beta1
- org.hornetq.rest:hornetq-rest (Maven): affected all versions; fixed in 2.5.0.Beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3599/ (Markdown: https://insights.sbomify.com/CVE-2014-3599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3599
- OSV: https://osv.dev/vulnerability/CVE-2014-3599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3599/
Summaries are generated and may contain mistakes; the official description above is the record.
