# CVE-2014-3603: Improper Validation of Certificate with Host Mismatch in Shibboleth Identity Provider and OpenSAML Java

> Man-in-the-middle attackers can spoof SSL servers because the library fails to verify hostname matching in X.509 certificates.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rm7v-gqfg-p2wc

## What is CVE-2014-3603?

CVE-2014-3603 is a medium-severity vulnerability in Shibboleth; OpenSAML Java Identity Provider (IdP), published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) HttpResource and (2) FileBackedHttpResource implementations in Shibboleth Identity Provider (IdP) before 2.4.1 and OpenSAML Java 2.6.2 do not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Weakness: CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2014-3603?

4 open source packages ship an affected version, including edu.internet2.middleware:shibboleth-identityprovider and org.opensaml:opensaml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.1 |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.1 |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.2 |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.2 |

Products: Shibboleth Identity Provider, Shibboleth Opensaml Java.

## How do I fix CVE-2014-3603?

Upgrade edu.internet2.middleware:shibboleth-identityprovider to 2.4.1 or later.

## Is CVE-2014-3603 being exploited?

There is no known exploitation of CVE-2014-3603 in the wild and no public exploit code.

## Other vulnerabilities in Shibboleth; OpenSAML Java Identity Provider (IdP)

- [CVE-2020-27978](https://insights.sbomify.com/CVE-2020-27978/): Denial of service in n/a (high 7.5)
- [CVE-2015-1796](https://insights.sbomify.com/CVE-2015-1796/): Improper Certificate Validation in Shibboleth Identity Provider and OpenSAML (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3603 and fix it if it is affected.

What it is: CVE-2014-3603 is a medium-severity vulnerability in Shibboleth; OpenSAML Java Identity Provider (IdP), published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3603 in the wild and no public exploit code.

Affected packages and fixed versions:
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.1
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.1
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.2
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3603/ (Markdown: https://insights.sbomify.com/CVE-2014-3603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3603
- OSV: https://osv.dev/vulnerability/CVE-2014-3603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3603/
Summaries are generated and may contain mistakes; the official description above is the record.
