{"answers":{"affected":"4 open source packages ship an affected version, including edu.internet2.middleware:shibboleth-identityprovider and edu.vt.middleware:vt-ldap. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-3607 in the wild and no public exploit code.","fix":"Upgrade edu.internet2.middleware:shibboleth-identityprovider to 2.4.2 or later.","what":"CVE-2014-3607 is a medium-severity vulnerability in n/a, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3607 and fix it if it is affected.\n\nWhat it is: CVE-2014-3607 is a medium-severity vulnerability in n/a, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3607 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.2\n- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.2\n- edu.vt.middleware:vt-ldap (Maven): affected all versions; fixed in 3.3.8\n- edu.vt.middleware:vt-ldap (Maven): affected all versions; fixed in 3.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3607/ (Markdown: https://insights.sbomify.com/CVE-2014-3607/index.md)","id":"CVE-2014-3607","markdown":"https://insights.sbomify.com/CVE-2014-3607/index.md","name":"CVE-2014-3607","record":{"aliases":["DEBIAN-CVE-2014-3607","GHSA-273v-g3x4-r3rc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Java LDAP library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof SSL servers due to improper hostname verification in the Ldaptive library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ldaptive","vendor":"ldaptive"},{"product":"vt-ldap","vendor":"ldaptive"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"DefaultHostnameVerifier in Ldaptive (formerly vt-ldap) does not properly verify that the server hostname matches a domain name in the subject's Common Name (CN) field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in vt-ldap","id":"CVE-2014-3607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2014"},"n_packages":4,"n_references":5,"next":{"headline":"OpenStack Compute (Nova)'s VMWare driver vulnerable to denial of service","id":"CVE-2014-3608"},"packages":[{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["0"],"last_affected":[],"package":"edu.internet2.middleware:shibboleth-identityprovider","purl":null,"source":"GHSA-273v-g3x4-r3rc"},{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["0"],"last_affected":[],"package":"edu.internet2.middleware:shibboleth-identityprovider","purl":"pkg:maven/edu.internet2.middleware/shibboleth-identityprovider","source":"GHSA-273v-g3x4-r3rc"},{"ecosystem":"Maven","fixed":["3.3.8"],"introduced":["0"],"last_affected":[],"package":"edu.vt.middleware:vt-ldap","purl":null,"source":"GHSA-273v-g3x4-r3rc"},{"ecosystem":"Maven","fixed":["3.3.8"],"introduced":["0"],"last_affected":[],"package":"edu.vt.middleware:vt-ldap","purl":"pkg:maven/edu.vt.middleware/vt-ldap","source":"GHSA-273v-g3x4-r3rc"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2014-3606"},"products":["n/a"],"published":"2018-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof SSL servers due to improper hostname verification in the Ldaptive library.","url":"https://insights.sbomify.com/CVE-2014-3607/"}