# CVE-2014-3607: Improper Certificate Validation in vt-ldap

> Man-in-the-middle attackers can spoof SSL servers due to improper hostname verification in the Ldaptive library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3607, GHSA-273v-g3x4-r3rc

## What is CVE-2014-3607?

CVE-2014-3607 is a medium-severity vulnerability in n/a, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DefaultHostnameVerifier in Ldaptive (formerly vt-ldap) does not properly verify that the server hostname matches a domain name in the subject's Common Name (CN) field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2014-3607?

4 open source packages ship an affected version, including edu.internet2.middleware:shibboleth-identityprovider and edu.vt.middleware:vt-ldap. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.2 |
| `edu.internet2.middleware:shibboleth-identityprovider` | Maven | All versions | 2.4.2 |
| `edu.vt.middleware:vt-ldap` | Maven | All versions | 3.3.8 |
| `edu.vt.middleware:vt-ldap` | Maven | All versions | 3.3.8 |

Products: Ldaptive Ldaptive, Ldaptive Vt-Ldap.

## How do I fix CVE-2014-3607?

Upgrade edu.internet2.middleware:shibboleth-identityprovider to 2.4.2 or later.

## Is CVE-2014-3607 being exploited?

There is no known exploitation of CVE-2014-3607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3607 and fix it if it is affected.

What it is: CVE-2014-3607 is a medium-severity vulnerability in n/a, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3607 in the wild and no public exploit code.

Affected packages and fixed versions:
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.2
- edu.internet2.middleware:shibboleth-identityprovider (Maven): affected all versions; fixed in 2.4.2
- edu.vt.middleware:vt-ldap (Maven): affected all versions; fixed in 3.3.8
- edu.vt.middleware:vt-ldap (Maven): affected all versions; fixed in 3.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3607/ (Markdown: https://insights.sbomify.com/CVE-2014-3607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3607
- OSV: https://osv.dev/vulnerability/CVE-2014-3607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3607/
Summaries are generated and may contain mistakes; the official description above is the record.
