{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.activemq:activemq-broker and org.apache.activemq:activemq-jaas. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3612 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-broker to 5.10.1 or later.","what":"CVE-2014-3612 is a high-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3612 and fix it if it is affected.\n\nWhat it is: CVE-2014-3612 is a high-severity authentication bypass vulnerability in Apache Activemq, published on 24 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3612 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.1\n- org.apache.activemq:activemq-broker (Maven): affected from 5.0.0; fixed in 5.10.1\n- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.1\n- org.apache.activemq:activemq-jaas (Maven): affected from 5.0.0; fixed in 5.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3612/ (Markdown: https://insights.sbomify.com/CVE-2014-3612/index.md)","id":"CVE-2014-3612","markdown":"https://insights.sbomify.com/CVE-2014-3612/index.md","name":"CVE-2014-3612","record":{"aliases":["DEBIAN-CVE-2014-3612","GHSA-72m6-23ff-7q26","UBUNTU-CVE-2014-3612"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Remote attackers can bypass authentication in Apache ActiveMQ by logging in with an empty password and valid username, triggering an unauthenticated bind.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Authentication in Apache WSS4J","id":"CVE-2014-3612","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"auth_bypass","year":"2014"},"n_packages":4,"n_references":6,"next":{"headline":"Other in n/a","id":"CVE-2014-3613"},"packages":[{"ecosystem":"Maven","fixed":["5.10.1"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-broker","purl":null,"source":"GHSA-72m6-23ff-7q26"},{"ecosystem":"Maven","fixed":["5.10.1"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-broker","purl":"pkg:maven/org.apache.activemq/activemq-broker","source":"GHSA-72m6-23ff-7q26"},{"ecosystem":"Maven","fixed":["5.10.1"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-jaas","purl":null,"source":"GHSA-72m6-23ff-7q26"},{"ecosystem":"Maven","fixed":["5.10.1"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-jaas","purl":"pkg:maven/org.apache.activemq/activemq-jaas","source":"GHSA-72m6-23ff-7q26"}],"prev":{"headline":"Race condition in n/a","id":"CVE-2014-3611"},"products":["n/a"],"published":"2015-08-24","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication in Apache ActiveMQ by logging in with an empty password and valid username, triggering an unauthenticated bind.","url":"https://insights.sbomify.com/CVE-2014-3612/"}