CVE-2014-3617 Moodle allows discovery of an author's username
Authenticated students can bypass Q&A forum restrictions to view author usernames without posting answers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-3617?
CVE-2014-3617 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 15 Sep 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The forum_print_latest_discussions function in mod/forum/lib.php in Moodle through 2.4.11, 2.5.x before 2.5.8, 2.6.x before 2.6.5, and 2.7.x before 2.7.2 allows remote authenticated users to bypass the individual answer-posting requirement without the mod/forum:viewqandawithoutposting capability, and discover an author's username, by leveraging the student role and visiting a Q&A forum.
Weakness: CWE-264
Which versions are affected by CVE-2014-3617?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.5.8 |
moodle/moodle Packagist | All versions | 2.5.8 |
moodle/moodle Packagist | From 2.6.0 | 2.6.5 |
moodle/moodle Packagist | From 2.6.0 | 2.6.5 |
moodle/moodle Packagist | From 2.7.0 | 2.7.2 |
moodle/moodle Packagist | From 2.7.0 | 2.7.2 |
Products include Moodle Moodle.
How do I fix CVE-2014-3617?
Upgrade moodle/moodle to a fixed version for your release line: 2.5.8, 2.6.5 or 2.7.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-3617 being exploited?
There is no known exploitation of CVE-2014-3617 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-p5j7-26wj-423j, MGASA-2014-0379.