# CVE-2014-3621: OpenStack Identity Keystone Exposure of Sensitive Information

> Authenticated users can read sensitive configuration options in OpenStack Keystone by crafting a malicious endpoint URL.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-3621, GHSA-8v8f-vc72-pmhc, PYSEC-2026-653, RHSA-2014:1789, RHSA-2014:1790, UBUNTU-CVE-2014-3621, USN-2406-1

## What is CVE-2014-3621?

CVE-2014-3621 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 2 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The catalog url replacement in OpenStack Identity (Keystone) before 2013.2.3 and 2014.1 before 2014.1.2.1 allows remote authenticated users to read sensitive configuration options via a crafted endpoint, as demonstrated by "$(admin_token)" in the publicurl endpoint field.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-3621?

3 open source packages ship an affected version, including keystone. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `openstack-keystone` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.3-2.el6ost |
| `openstack-keystone-doc` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.3-2.el6ost |
| `python-keystone` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.3-2.el6ost |
| `openstack-keystone` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.3-2.el7ost |
| `openstack-keystone-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.3-2.el7ost |
| `python-keystone` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.3-2.el7ost |

Products: Canonical Ubuntu Linux, Openstack Keystone, Redhat Openstack.

## How do I fix CVE-2014-3621?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2014-3621 being exploited?

There is no known exploitation of CVE-2014-3621 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3621 and fix it if it is affected.

What it is: CVE-2014-3621 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 2 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3621 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3621/ (Markdown: https://insights.sbomify.com/CVE-2014-3621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3621
- OSV: https://osv.dev/vulnerability/CVE-2014-3621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3621/
Summaries are generated and may contain mistakes; the official description above is the record.
