CVE-2014-3627 Improper Link Resolution Before File Access in Apache Hadoop

Medium 5.0 Published Updated

Remote cluster users can exploit a symlink attack in the distributed cache to make files world-readable, exposing sensitive data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-3627?

CVE-2014-3627 is a medium-severity path traversal vulnerability in n/a, published on 5 Dec 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The YARN NodeManager daemon in Apache Hadoop 0.23.0 through 0.23.11 and 2.x before 2.5.2, when using Kerberos authentication, allows remote cluster users to change the permissions of certain files to world-readable via a symlink attack in a public tar archive, which is not properly handled during localization, related to distributed cache.

Weakness: CWE-59

Which versions are affected by CVE-2014-3627?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-client. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-client MavenFrom 0.23.01.0.1
org.apache.hadoop:hadoop-client MavenFrom 0.23.01.0.1
org.apache.hadoop:hadoop-client MavenFrom 2.0.02.5.2
org.apache.hadoop:hadoop-client MavenFrom 2.0.02.5.2

Products include Apache Hadoop.

How do I fix CVE-2014-3627?

Upgrade org.apache.hadoop:hadoop-client to a fixed version for your release line: 1.0.1 or 2.5.2.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2014-3627 being exploited?

There is no known exploitation of CVE-2014-3627 in the wild and no public exploit code.

Sources

Also known as GHSA-jpmf-8cj2-595g.

Is CVE-2014-3627 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free