# CVE-2014-3627: Improper Link Resolution Before File Access in Apache Hadoop

> Remote cluster users can exploit a symlink attack in the distributed cache to make files world-readable, exposing sensitive data.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jpmf-8cj2-595g

## What is CVE-2014-3627?

CVE-2014-3627 is a medium-severity path traversal vulnerability in n/a, published on 5 Dec 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The YARN NodeManager daemon in Apache Hadoop 0.23.0 through 0.23.11 and 2.x before 2.5.2, when using Kerberos authentication, allows remote cluster users to change the permissions of certain files to world-readable via a symlink attack in a public tar archive, which is not properly handled during localization, related to distributed cache.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2014-3627?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-client` | Maven | From 0.23.0 | 1.0.1 |
| `org.apache.hadoop:hadoop-client` | Maven | From 0.23.0 | 1.0.1 |
| `org.apache.hadoop:hadoop-client` | Maven | From 2.0.0 | 2.5.2 |
| `org.apache.hadoop:hadoop-client` | Maven | From 2.0.0 | 2.5.2 |

Products: Apache Hadoop.

## How do I fix CVE-2014-3627?

Upgrade org.apache.hadoop:hadoop-client to a fixed version for your release line: 1.0.1 or 2.5.2.

## Is CVE-2014-3627 being exploited?

There is no known exploitation of CVE-2014-3627 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3627 and fix it if it is affected.

What it is: CVE-2014-3627 is a medium-severity path traversal vulnerability in n/a, published on 5 Dec 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3627 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-client (Maven): affected from 0.23.0; fixed in 1.0.1
- org.apache.hadoop:hadoop-client (Maven): affected from 0.23.0; fixed in 1.0.1
- org.apache.hadoop:hadoop-client (Maven): affected from 2.0.0; fixed in 2.5.2
- org.apache.hadoop:hadoop-client (Maven): affected from 2.0.0; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3627/ (Markdown: https://insights.sbomify.com/CVE-2014-3627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3627
- OSV: https://osv.dev/vulnerability/CVE-2014-3627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3627/
Summaries are generated and may contain mistakes; the official description above is the record.
