# CVE-2014-3628: Improper Neutralization of Input During Web Page Generation in Apache Solr

> Remote attackers can inject arbitrary web script or HTML into the Apache Solr Admin UI Stats page via the fieldvaluecache object.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jan 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wgw2-gw4v-9w4j

## What is CVE-2014-3628?

CVE-2014-3628 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Jan 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-3628?

2 open source packages ship an affected version, including org.apache.solr:solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr` | Maven | From 4.0.0 | 4.10.3 |
| `org.apache.solr:solr` | Maven | From 4.0.0 | 4.10.3 |

Products: Apache Solr.

## How do I fix CVE-2014-3628?

Upgrade org.apache.solr:solr to 4.10.3 or later.

## Is CVE-2014-3628 being exploited?

There is no known exploitation of CVE-2014-3628 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3628 and fix it if it is affected.

What it is: CVE-2014-3628 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Jan 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3628 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr (Maven): affected from 4.0.0; fixed in 4.10.3
- org.apache.solr:solr (Maven): affected from 4.0.0; fixed in 4.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3628/ (Markdown: https://insights.sbomify.com/CVE-2014-3628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3628
- OSV: https://osv.dev/vulnerability/CVE-2014-3628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3628/
Summaries are generated and may contain mistakes; the official description above is the record.
