# CVE-2014-3643: jersey: XXE via parameter entities

> Attackers can exploit XML External Entity vulnerabilities in the Jersey SAX parser to read sensitive files or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5m48-vr54-vmh3, MINI-26pq-rw3f-4rg9

## What is CVE-2014-3643?

CVE-2014-3643 is a high-severity vulnerability in jersey, published on 15 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jersey: XXE via parameter entities not disabled by the jersey SAX parser

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2014-3643?

2 open source packages ship an affected version, including com.sun.jersey:jersey-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.sun.jersey:jersey-core` | Maven | All versions | 1.13 |
| `com.sun.jersey:jersey-core` | Maven | All versions | 1.13 |

Products: Jersey Project Jersey.

## How do I fix CVE-2014-3643?

Upgrade com.sun.jersey:jersey-core to 1.13 or later.

## Is CVE-2014-3643 being exploited?

There is no known exploitation of CVE-2014-3643 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3643 and fix it if it is affected.

What it is: CVE-2014-3643 is a high-severity vulnerability in jersey, published on 15 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3643 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.sun.jersey:jersey-core (Maven): affected all versions; fixed in 1.13
- com.sun.jersey:jersey-core (Maven): affected all versions; fixed in 1.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3643/ (Markdown: https://insights.sbomify.com/CVE-2014-3643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3643
- OSV: https://osv.dev/vulnerability/CVE-2014-3643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3643/
Summaries are generated and may contain mistakes; the official description above is the record.
