# CVE-2014-3651: Keycloak vulnerable to uncontrolled resource consumption

> Remote attackers can cause denial of service in Keycloak by sending a large size parameter to the QR code generation endpoint.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-r32r-3977-cgc3

## What is CVE-2014-3651?

CVE-2014-3651 is a high-severity denial of service vulnerability in n/a, published on 29 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JBoss KeyCloak before 1.0.3.Final allows remote attackers to cause a denial of service (resource consumption) via a large value in the size parameter to auth/qrcode, related to QR code generation.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2014-3651?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 1.0.3 |
| `org.keycloak:keycloak-core` | Maven | All versions | 1.0.3 |

Products: Keycloak Keycloak.

## How do I fix CVE-2014-3651?

Upgrade org.keycloak:keycloak-core to 1.0.3 or later.

## Is CVE-2014-3651 being exploited?

There is no known exploitation of CVE-2014-3651 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12161](https://insights.sbomify.com/CVE-2017-12161/): Moderate severity vulnerability that affects org.keycloak:keycloak-core (high 8.8)
- [CVE-2014-3709](https://insights.sbomify.com/CVE-2014-3709/): JBoss Keycloak CSRF Vulnerability (high 8.8)
- [CVE-2017-12159](https://insights.sbomify.com/CVE-2017-12159/): Keycloak CSRF Vulnerability (high 7.5)
- [CVE-2017-12158](https://insights.sbomify.com/CVE-2017-12158/): Keycloak Reflected XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3651 and fix it if it is affected.

What it is: CVE-2014-3651 is a high-severity denial of service vulnerability in n/a, published on 29 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3651 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 1.0.3
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3651/ (Markdown: https://insights.sbomify.com/CVE-2014-3651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3651
- OSV: https://osv.dev/vulnerability/CVE-2014-3651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3651/
Summaries are generated and may contain mistakes; the official description above is the record.
