# CVE-2014-3655: JBoss KeyCloak is vulnerable to soft token deletion via CSRF

> Attackers can force authenticated users to delete soft tokens via CSRF, impacting KeyCloak identity management security.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-237q-6hjp-pchq

## What is CVE-2014-3655?

CVE-2014-3655 is a medium-severity vulnerability in Redhat Keycloak, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

JBoss KeyCloak is vulnerable to soft token deletion via CSRF

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2014-3655?

2 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 1.0.2.Final |
| `org.keycloak:keycloak-services` | Maven | All versions | 1.0.2.Final |

Products: Redhat Jboss Enterprise Web Server, Redhat Keycloak.

## How do I fix CVE-2014-3655?

Upgrade org.keycloak:keycloak-services to 1.0.2.Final or later.

## Is CVE-2014-3655 being exploited?

There is no known exploitation of CVE-2014-3655 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3655 and fix it if it is affected.

What it is: CVE-2014-3655 is a medium-severity vulnerability in Redhat Keycloak, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3655 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 1.0.2.Final
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 1.0.2.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3655/ (Markdown: https://insights.sbomify.com/CVE-2014-3655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3655
- OSV: https://osv.dev/vulnerability/CVE-2014-3655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3655/
Summaries are generated and may contain mistakes; the official description above is the record.
