# CVE-2014-3656: JBoss KeyCloak Cross-site Scripting Vulnerability

> An XSS vulnerability in KeyCloak's login status iframe allows attackers to execute scripts in the context of the identity provider.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-px42-mr8m-cpgh

## What is CVE-2014-3656?

CVE-2014-3656 is a medium-severity cross-site scripting vulnerability in JBoss KeyCloak, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

JBoss KeyCloak: XSS in login-status-iframe.html

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-3656?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 1.1.0.Beta1 |
| `org.keycloak:keycloak-core` | Maven | All versions | 1.1.0.Beta1 |

Products: Redhat Jboss Keycloak.

## How do I fix CVE-2014-3656?

Upgrade org.keycloak:keycloak-core to 1.1.0.Beta1 or later.

## Is CVE-2014-3656 being exploited?

There is no known exploitation of CVE-2014-3656 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/keycloak__keycloak_CVE-2014-3656_1-0-5-Final (github_poc): https://github.com/shoucheng3/keycloak__keycloak_CVE-2014-3656_1-0-5-Final

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3656 and fix it if it is affected.

What it is: CVE-2014-3656 is a medium-severity cross-site scripting vulnerability in JBoss KeyCloak, published on 10 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3656 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 1.1.0.Beta1
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 1.1.0.Beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3656/ (Markdown: https://insights.sbomify.com/CVE-2014-3656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3656
- OSV: https://osv.dev/vulnerability/CVE-2014-3656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3656/
Summaries are generated and may contain mistakes; the official description above is the record.
